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 INTRODUCTION 
Quantities 2 Plans 
Quantities 2 Plans (Q2P) was developed by the Wisconsin Department of Transportation (WisDOT) to create a 
single repository of bid item data for maintaining a live link between the engineer’s estimate, quantity calculations, 
and the construction plan miscellaneous quantity (MQ) sheets. Q2P is a Microsoft® Excel® Add-in based 
application that contains all the current WisDOT bid items with automatic updates capability (from the WisDOT 
AASHTOWare Project Database). 

MQ tables are created in Q2P and are able to be linked into Microsoft® PowerPoint® or AutoCAD® Civil 3D for MQ 
plan sheet creation. The estimate cost data is updated by design staff from scoping phase through PS&E, at which 
point the estimate is imported into AASHTOWare Project Preconstruction® (AWP Preconstruction). When a 
project estimate is submitted to Central Office at PS&E phase, Q2P is no longer considered the official engineer’s 
estimate. At this stage, region policy dictates whether Q2P is kept current with the changed data in AWP 
Preconstruction (from PS&E review revisions, addenda, etc.) 

The WisDOT Bureau of Information Technology Services (BITS) and WisDOT Q2P Support Committee maintain Q2P 
(the Excel Add-in and the worksheet templates used by the add-in), and provide support via the 
DOTQ2P@dot.wi.gov (DOT Q2P) email address. The WisDOT Estimating Group is an additional resource that 
provides best practices and information related to construction cost estimating. 

Visit https://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx to 
subscribe to the WisDOT Q2P email list for Q2P news or to find the name of power users in your region for support. 
Notifications for updates, or tips & tricks, etc. are shared via this distribution list. 

Confidentiality Notice 
Engineering estimates are always treated as confidential before, during and after the letting by WisDOT. Engineer 
estimate data should not be released outside of WisDOT with the exception of the Federal Highway Administration 
and engineering consultants working directly for WisDOT. The State Transportation Agency (i.e. WisDOT) policy is 
further explained in Appendix C. 

When sharing information with the public, or when a general estimate is required in a project report (e.g. the 
Work Zone Transportation Management Plan), obtain the project estimate range from region planning section’s 
Public Report. 

mailto:DOTQ2P@dot.wi.gov
https://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx
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 USING QUANTITIES 2 PLANS 

1. Before You Get Started 
Quantities 2 Plans (Q2P) requires system files to be installed. 

WisDOT Staff: Will need to contact the DOT IT Service Desk for installation of the necessary system files.  
External Staff: Will need to download the installer from the Q2P website. 

Q2P updates are pushed to WisDOT staff’s workstations by IT. Consultants must 
download Q2P updates posted on the Q2P website. 

As part of the installation process, each user will need to go through a few additional steps to finish the 
installation of Q2P on your computer for your logon account.  If Q2P ever needs to be re-installed, if you get a 
new computer, or if another user needs to login and use Q2P on your computer, the following steps need to be 
performed prior to the first use of Q2P. 

Figure 1.1 Windows “Apps & Features” menu. Figure 1.2 Window with “Repair Q2P Excel Add-In” tool. 

1. Go to your Start Menu and select “Settings” (Gear shaped icon) 
2. Select “Apps”. 
3. In the next window that appears, make sure “Apps & Features” is selected (Figure 1.1). 
4. In the search bar, type in “q2p”. 
5. You’ll see an app titled Q2P Excel Add-in with two buttons available to press.  Press the “Modify” button. 
6. A window should pop up with two radio buttons (Figure 1.2).  Select the “Repair Q2P Excel Add-in” radio 

button and click the “Finish” button. 
7. After Q2P is repaired, you can close these windows and open up excel with a new workbook.  If everything 

worked, you should see a new Excel ribbon along the top titled “Q2P”. 

If you have any issues getting this far, please feel free to contact DOTQ2P@dot.wi.gov 

Q2P is currently supported under Microsoft® Office 2012 and up with Windows 7 and up and must have the .NET 
Framework 4.6 and up installed. 

https://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx
https://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx
mailto:DOTQ2P@dot.wi.gov
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2. Begin a New Project – Entering Project Information 
1. Open a new Excel workbook and navigate to the Q2P ribbon tab (Figure 2.1). This tab houses all 

of Q2P’s specific commands and functionality. 

A Q2P workbook can only handle a single project ID.  If you are working on multiple project IDs 
that will be LET together as one proposal and plan set, then you will need multiple Q2P 
workbooks to be able to import each project IDs estimate into AWP separately and one 
workbook to combine the quantity tables together for the projects’ MQ sheets. 

Figure 2.1 Q2P-specific commands found under the Q2P tab. 

2. An internet connection is required for this step, and the project setup window shown below, may 
take 10 seconds or more to display depending on your internet connection. Q2P will contact 
WisDOT’s AWP server and copy the list of published Bid Items to this Q2P workbook. Select New 
(Figure 2.2) from the Project section of the Q2P ribbon to initialize the project setup window 
(Figure 2.3) and enter all project information. The information in Q2P must match FIIPS 
information. 

If the project information does not match FIIPS exactly, errors will result when trying 
to export and upload to AWP Preconstruction. 

The one exception to the rule above is if the project title uses the ampersand (&). If this is the 
case, the XML export from Q2P will not successfully load into AWP. As a workaround, remove the 
“&” or replace it with “and” in the Q2P export XML then edit it back in once uploaded into AWP. 

Figure 2.2 The “New” button under the Project section of the Q2P ribbon. 
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Figure 2.3 Project Setup window. 

3. Select “OK” when finished to save the workbook.   There will be a slight delay after hitting “OK” as 
Q2P will contact the AWP server and copy the bid item data for the chosen spec. book year to 
your machine. When saving, use the 00000000_mqw.xlsx naming convention, where 00000000 
is the associated construction ID. Save the Q2P workbook in your project estimate folder, or where 
your region’s policy dictates. A date or other version related text can be added to the file name 
(e.g., 12345678_mqw-30REVIEW.xlsx). 

4. Select Category Setup (Figure 2.4) from the Project section of the Q2P ribbon to initialize the 
category setup window (Figure 2.3) and enter all category information. Select OK when finished. 
This process must be repeated for each new category. 

Figure 2.4 The “Category Setup” button under the Project section of the Q2P ribbon. 

Figure 2.5 Category Setup window. 
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If category information must be updated, this is possible by selecting the existing 
category from the Category Drop-down and entering the new information as needed 
to overwrite the existing category. 

This updating method also works for deleting unused categories, where you simply 
need to select blank options to clear the existing category. (See section 6.2 Delete 
Categories from Project for more information.) 

This information can all be obtained from FIIPS through Project > Funding… and clicking Category # 00n0 
for more detailed information (See Figures 2.6 and 2.7). External users should contact the DOT Project 
Manager to obtain this information. The information in Q2P must match FIIPS information EXACTLY. 

Figure 2.6 FIIPS menu navigation. 

Figure 2.7 FIIPS project information 

Always use the dialog box to edit the category information and do not edit their headings (i.e. 
“Categories”) on the “Bid Items” worksheet. 
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Figure 2.8 Categories, Federal Work Types and Funding entry in Q2P. 

If the desired work type is not in the list, type it in (50 – New Tunnel, for example). 

5. Save the changes made to this workbook. Saving (to your local computer or a network drive) will 
enable Excel’s Autosave feature, reducing the risk of data loss in the event of a program crash. 
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3. Bid Item Data 
The Data section of the Q2P ribbon houses two bid item commands: 

Published Bid Items and Project Bid Items 

3.1 Published Bid Items 

Q2P > Data > Published Bid Items (Figure 3.1) will display the most current list of bid items downloaded 
from the AWP server based upon the Spec. Book year chosen in the Project Setup screen (Figure 3.2). This is 
for informational purposes only. 

Figure 3.1 “Published Bid Items” command. 

Figure 3.2 List of currently published bid items from AWP. 
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3.2 Project Bid Items 

Q2P > Data > Project Bid Items (Figure 3.3) will display the active workbook’s (a.k.a. project’s) list of bid 
items. When a new Q2P project is started, the program creates a snapshot of the published bid items based 
upon data from the AWP server for the chosen Spec. Book year. This Project Bid Items list (Figure 3.4) is also 
editable by the user to add or delete user defined items. See section 7. Items with Supplemental 
Descriptions. 

Figure 3.3 “Project Bid Items” command. 

Figure 3.4 List of currently available items saved locally to your machine for use in Q2P. 
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3.3 Updating and Reconciling the Standard Bid Item List 

Most projects will not be designed in less than a year which requires the need to contend with WisDOT’s 
yearly updates to its Standard Specification list of bid items and Standardized Special Provision items. 
Although users are unable to manually add or delete standard bid items, Q2P does have a Reconciliation Tool 
available (Figure 3.5) to compare the list of bid items in the Q2P workbook with the list of bid items in the 
AWP database server based upon the chosen spec. book year. This tool also allows users to update their 
Project Bid Item list with any new bid items from year to year when they change the Spec. Book year in the 
Project Setup window or if the chosen Spec book list of items has had changes made in AWP. 

Q2P will attempt to query the AWP database to pull the current bid item master list each time the user opens 
Q2P from a new Excel session. Alternatively, the user can force an update to the Project Bid Item list by 
pressing the Published Bid Items button in the Q2P ribbon. Both methods require an active internet 
connection. 

To check for any bid item changes: 

1. Select Q2P > Data > Project Bid Items.  If there are any changes, users will notice a string of red 
text (Figure 3.5) next to the blue “+” in the “Project Bid Items” dialog box. 

Figure 3.5 Reconciliation Tool in “Project Bid Items” dialog box. 

2. Click on the red colored text to bring up the “Reconcile Project Bid Items with Published Bid 
Items” dialog box (Figure 3.6). 
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Figure 3.6 Reconciliation Tool in “Project Bid Items” dialog box. 

3. Review the “Reconcile Project Bid Items with Published Bid Items” dialog box to view each 
specific item change. 

A. Bid Items in this Project but not in the Published:  This section displays standard items that are 
contained in your Q2P file, but are not housed within the AWP list.  This section is normally blank, 
but an item showing up in this window could indicate that an item has been removed from the AWP 
master list that your Q2P file still utilizes.  This section is for informational purpose only. 

B. New Bid Items in the Published but not in this Project: This section displays any new bid items that 
were added to the AWP master list that did not exist when your Q2P file was created. Typically, these 
are the new items from a yearly specification book update.   If you want to add these bid items to your 
current Q2P projects bid item list, select the item(s) you want to add, then click on the “^Add to 
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Project^” button located just above this section. This will insert the new specification bid items to 
your Q2P project bid items list so you can create the associated MQ sheets. 

If a new bid item is added that requires a supplemental description, you will also need 
to create a new bid item as outlined in section 7.1 Add a New Item to the Project Bid 
Items List prior to creating an MQ sheet or adding it to an existing MQ sheet. 

C. Bid Items in this Project need update: & Bid Items in the Published have changes:   These two sections 
display any changes to previously existing bid items numbers.   This could include description changes, 
unit of measurement changes, or items being marked as obsolete. 

Figure 3.7 “Change” section of the Reconciliation Tool with highlighted differences selected. 

The section on the Left-hand side displays the bid item information as it is currently in your Q2P file.  
The section on the Right-hand side displays the bid item information as it is currently in the AWP 
database. Clicking on the “Highlight Differences” button will highlight what has changed (Figure 3.7).  
The columns in this window are expandable to make it easier to read the entire descriptions of bid 
items.  Once the changes are highlighted, you can decide if you want to click on “Accept Changes” to 
update the Q2P file.  This will make your Q2P file match the information in AWP. 

Prior to accepting any changes, check to see if you have MQ sheets created for any of the updated 
items. The descriptions, supplemental descriptions and unit of measure are not dynamically 
linked to the MQ sheet. Therefore, you will need to manually update these fields on your MQ 
sheet. 

If the item being updated requires a supplemental description, then any Q2P pre-
made “.01” items need to be manually updated following the procedure in section 7.1 
Add a New Item to the Project Bid Items List. Alternatively, if the item requires a 
supplemental description, and the change was to the unit of measure or description, 
the Q2P existing pre-made “.01” item will need to be deleted. Then a new “.01” item 
will need to be added to the Project Bid Items list using the recently changed bid item 
as a base. 
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4. Contingency Amounts 
Do not include construction contingencies in the Delivery Cost field in Q2P, and do not keep 
contingencies in the final estimate. 

In Q2P, users can add a transient, mock bid item for contingencies for each category. 

A separate contingency item is required for each category as the appropriate percentage will vary. Multiple 
items per each category can also be used, if separating the costs is desired (e.g. Traffic Control and Drainage 
both in Cat. 0010). 

Delivery cost is different than contingency amounts used in preliminary cost estimates; it is an estimate of 
staffing costs during the construction phase of a project. Prior to final submittal of the cost estimate, this 
value should be coordinated with the delivery cost/percentage in FIIPS for the project. 

To add contingencies, utilize a Lump Sum (LS) SPV item and see section 7. Items with Supplemental 
Descriptions. Remember to reduce the cost amount of your contingency item as you add the individual bid 
items to your estimate related to the contingency item.   This keeps your total estimate cost from being 
artificially inflated as you give periodic cost updates throughout the lifespan of the design project. 



Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 20 

5. Adding Bid Items and MQ Sheets 
From the MQ Sheet section of the Q2P ribbon, Q2P > MQ Sheet > Create MQ Sheet (Figure 5.1) will 
bring up the dialog box to add the item/s and create the miscellaneous quantity (MQ) sheet/s in one 
step.  If multiple bid items are created on one MQ sheet, that is known as a “summary sheet.” 

Figure 5.1 “Create MQ Sheet” command. 

1. Once the “Create MQ Sheet…” dialog box appears (Figure 5.2), select the desired items and the 
appropriate categories to be associated with those items. You can type part of the item 
description in the search bar to navigate to a particular item in the list, but be aware that Q2P is 
unable to search within supplemental descriptions. Select multiple items/categories by holding 
either the “Shift” or “Ctrl” keys and clicking different items, or by clicking and dragging across your 
selection. To completely reset the selection, use either the “Reset Bid Items Selection” or the 
“Reset Categories Selection” buttons. 

Use of the Shift key allows for the selection of all items between the two selected; use 
of the Ctrl key allows for discrete selection and de-selection with every click. 

Use caution when holding the “Crtl” key to select multiple items. If you accidentally release the 
“Crtl” key while selecting an additional item, all previously selected items in the list will no longer 
be selected. 

Figure 5.2 “Create MQ Sheet…” dialog box. 
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2. To finish, select “Create New Sheet” to put all selected bid items on one summary sheet, or select 
“Create Separate Sheets” to create separate individual MQ sheets for each bid item. 

If creating a summary sheet, remember to name the sheet with a numerical prefix so 
that it is inserted in the order of your preference. (i.e. 202-Clearing and Grubbing) 

If an MQ sheet is created in error, using the Excel undo/redo is not recommended. If an MQ sheet 
must be deleted after it is created, use the Q2P Remove Bid Item command. 

Occasionally the Excel worksheets will get out of numeric order when creating new MQ sheets. Use Q2P 
> Tool > Order MQ Sheets (Figure 5.3) to reorder the worksheets. 

Figure 5.3 “Order MQ Sheets” command. 
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6. Adding/Deleting Categories 
Users can easily add additional categories and delete unwanted categories from existing MQ sheets using 
the following workflows. 

6.1 Add Categories 

Before adding additional categories to an existing MQ sheet, confirm that those additional categories have 
already been set up via step 4 of section 2. Begin a New Project. To add additional categories to an existing 
MQ sheet: 

Figure 6.1 Adding a category to an existing MQ sheet. 

1. Copy and paste the text and formatting of a category name and total that is already on the MQ 
sheet or summary sheet and place them in the same columns. 

2. Change the text to the desired category. 
3. Select Q2P > MQ Sheet > Rebuild References to bring up the “Rebuilding reference in MQ Sheet” 

dialog box (Figure 6.2) and select “Start Rebuilding” to create the proper named ranges for the 
bid item total(s). 
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Figure 6.2 “Rebuilding reference in MQ Sheet” dialog box after references have been built. 

4. Select Q2P > Tool > Go to “Bid Items” or use the right-click menu to navigate back to the main 
“Bid Items” worksheet. 

5. Use Q2P > Tool > Update Bid Items(s) and select “Update All in this Worksheet”. Select “Yes” to 
confirm and refresh the links to the “Bid Items” worksheet. Click “OK” to close the dialog box and 
see the reflected changes (Figure 6.3). 

Figure 6.3 Updated bid item quantities after adding another category. 
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6.2 Delete Categories from Project 

Only the last category (max. category number) can be deleted from Category Setup. Before 
proceeding, verify that the category to be deleted is not being used in any MQ Sheet. 

To delete a category (e.g. Category 0030) out of the entire project or from the “Bid Items” worksheet: 

Figure 6.4 Category Setup window. 

1. Use Q2P < Project < Category Setup to bring up the “Setup Category, Federal Work Type & 
Category Description…” dialog box. 

2. Select the last existing category (Category 0030 in this case) from the “Category” drop-down. 
3. Select “Delete” to finish and close the dialog box. 

The row previously containing the deleted category should be cleared as in Figure 6.5. 

Figure 6.5 Category 0030 is no longer visible in the list of categories. 

If a category is listed on an MQ sheet, but not defined on the “Bid Items” worksheet, Q2P will not 
recognize any totals for that category and they will not appear in the Cost Report or the XML files 
to Estimator or AWP. 
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6.3 Delete Categories from MQ Sheets 

Delete unneeded category rows (using Excel commands) from the individual MQ sheets. Do not keep 
empty Cat. 0020, 0030 totals on the MQ sheet or summary sheet (unless intended to be used at a later 
time.) To delete unneeded categories from an existing MQ sheet: 

Figure 6.6 Deleting a category from an existing MQ sheet. 

1. Select the rows of cells of the category to delete by clicking and dragging over the row numbers 
(for example, rows 15-20 in Figure 6.6). 

2. Right click on the selection and click “Delete”. 
3. Use Q2P > MQ Sheet > Rebuild References and select “Start Rebuilding” to refresh the named 

ranges for the bid item total(s). 
4. Use Q2P > Tool > Update Bid Items(s) and select “Update All in this Worksheet”. Select “Yes” to 

confirm and refresh the links to the “Bid Items” worksheet. Click “OK” to close the dialog box. 
5. Use Q2P > Tool > Go to “Bid Items” or use the right-click menu to navigate back to the main “Bid 

Items” worksheet to see the reflected changes (Figure 6.7). 
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Figure 6.7 Updated bid item quantities after deleting unneeded category. 

Do not overwrite an existing category on an MQ sheet to change it.  For example, you create a 
sheet with structure items on it under CAT 0010 and realize those items should have been under 
CAT 0020.  If you change the 0010 to 0020 on the MQ sheet and run the Rebuild References and 
Update Bid Items command; Q2P will create the named ranges for the 0020 category, however 
it will not delete the named ranges for the 0010 category.  Q2P now has two different named 
ranges pointing to the same cell and will show a double quantity on the main Bid Items sheet. 
For this case, it is better to copy your quantities somewhere else temporarily, delete all the 
items from this worksheet, then create a new MQ sheet with the correct category for those bid 
items.  
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7. Items with Supplemental Descriptions 
Items that contain ( ) in their ITEM DESCRIPTION and SPV items are required to have a supplemental 
description entered, and a unique bid item number assigned. This is true for any item that has extra digits 
appended to the item number – item numbers must be unique if they are intended to pay for different things 
within the contract. 

For these special items in Q2P, the bid item numbers must be set up properly in the Project Bid 
Items list PRIOR to creating the item MQ sheets. 

For contracts with multiple projects, remember that items that need a supplemental description, such as 
“Finishing Roadway (project),” need unique numbers for each project, for example: 

Finishing Roadway (01. 1234-56-78); Finishing Roadway (02. 9999-99-79) 
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7.1 Add a New Item to the Project Bid Items List Using the “Project Bid Items” Dialog Box 

Be aware that this only inserts a new item into this project’s Project Bid Items list, and either the 
associated MQ sheet needs to be created via workflow 5. Adding Bid Items and MQ Sheets, or this 
item needs to be added to an existing MQ sheet via workflow 8.2 Inserting a Bid Item into an 
Existing MQ Sheet. 

Figure 7.1 “Project Bid Items” dialog box. 

1. Select Q2P > Data > Project Bid Items to bring up the “Project Bid Items” dialog box. 

2. Select the blue “+” button to add a new item to the bottom of the list. 

3. Make sure the “Edit Mode” box is checked. 
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4. Select a base bid item to modify. 

If you are adding a single iteration of an item requiring a supplemental description, 
Q2P includes pre-made “.01” versions of such items for the user to simply select from 
the list and modify. (See Figure 7.2) 

The .S items that do not require a supplemental description are only used once and 
therefore, can be selected directly from the list when creating MQ sheets. Note how 
these .S items have a blank field in the “Supplemental Description” column. (See 
Figure 7.2) 

Figure 7.2 Examples of special items. (SPV items included, but not shown) 

5. Add the desired supplemental numerical suffix with (typically) two digits. 

The item number suffix can and typically restarts at 01 for each different bid item. 
The numbers do not need to be sequential, and in some cases, it is beneficial to leave 
a gap in numbering, especially for when multiple items will be defined in a single 
special provision, so additional sizes, types, etc. can later be easily added and grouped 
with like items. (See Figure 7.3) 

6. Add the desired supplemental description using the XX. Description format. 
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7. Select “Update” to add the item to the “Project Bid Items” list for future use. 

When editing the SPV item descriptions, the word “Special” is retained even though 
it would not be in the special provision language. (See Figure 7.3) 

Figure 7.3 Sample list of supplemental descriptions after creating MQ sheets. 

More information on naming ( ) and SPV items can be found in FDM 19-15-80 and FDM 19-15-85. 

https://wisconsindot.gov/rdwy/fdm/fd-19-15.pdf
https://wisconsindot.gov/rdwy/fdm/fd-19-15.pdf
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7.2 Editing of Supplemental Descriptions After Creation 

The “Bid Items” worksheet and the MQ sheets are not dynamically linked for the description text. 
The bid item description on the MQ sheet is just a copy of the bid item description and 
supplemental description text. Any changes by the user to the supplemental description via the 
Project Bid Items list will need to be manually updated on the MQ sheet. This allows the user to 
customize the MQ sheet headers without breaking any links or having their edits overwritten 
when the Update Bid Item(s) command is used. All the data in Q2P is refenced by bid item 
number, so when a sheet is created, all data is tied to that number and the user changing that 
number would remove the connection to that data. 

Figure 7.4 Edits made via “Project Bid Items” dialog box. 
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1. Select Q2P > Data > Project Bid Items to bring up the Project Bid Items dialog box. 

2. Select the bid item which requires editing the supplemental description. 

3. Make sure the “Edit Mode” box is checked. 

4. Make the desired changes to either the “Ref Item Name” number or the “Supplemental Description.” 

If the item you are trying to edit is currently part of a MQ sheet, you will not be able 
to edit the “Ref Item Name” field; only the “Supplemental Description” field. In order 
to edit the “Ref Item Name,” you will need to remove that bid item from all MQ sheets 
that contain that item. Use caution as this could delete any notes or quantity 
information for this item that you may want to save. 

5. Select “Update” to apply the changes. 

If the numerical suffix of a user defined item needs to change (e.g. 203.0200.05 to 203.0200.04) 
and the MQ sheet already exists for it, the Rename MQ Sheet command must be run. Refer to 
section 8.3 Renaming an MQ Sheet or Summary Sheet for more guidance on how to do this. 
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8. Combining Multiple Bid Items into One Summary Sheet 

8.1 Before You Combine Items 

Before entering quantities into the MQ sheets, it is best to combine the like items into summary tables. This 
is preferably done INITIALLY using workflow 5. Adding Bid Items and MQ Sheets and opting to add the items 
onto a single MQ sheet (a.k.a. summary sheet), but this can also be done by inserting a bid item into an existing 
MQ sheet using the following workflow in 8.2 Inserting a Bid Item into an Existing MQ Sheet. 

It is good practice to set up all the item MQ sheets categories BEFORE combining them onto a summary sheet 
because adding or deleting categories on the summary sheet requires links to be recreated. Run Q2P > MQ 
Sheet > Rebuild References (Figure 8.1) whenever adding or deleting categories from an MQ sheet or 
summary sheet to refresh or create the proper links. Run Q2P > Tool > Update Bid Item(s) (Figure 8.1) to 
ensure the “Bid Items” worksheet is also refreshed. 

Figure 8.1 “Rebuild References” and “Update Bid Item(s)” commands. 

Q2P will track bid item totals that are shown in multiple sheets, so it is important to properly 
delete any data that is no longer needed. Otherwise, bid item totals may be skewed for cost 
estimating. 

8.2 Inserting a Bid Item into an Existing MQ Sheet 

1. Navigate to the existing MQ sheet via scrolling to the appropriate tab in Excel or use the right-click 
menu while hovering on the desired bid item from the main Bid Items worksheet then select the sheet 
you want to navigate to (Figure 8.2 and Figure 8.3). 

Figure 8.2 Right-Click menu. Figure 8.3 Go to MQ sheet dialog box. (Will display multiple 
sheets if the item is found in multiple sheets.) 

You can also navigate back to the “Bid Items” worksheet via the “Return to “Bid 
Items”” button in the right-click menu. See step 2 of Appendix B-2 Quick Navigation. 
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2. From the MQ Sheet section of the Q2P ribbon, select Q2P > MQ Sheet > Insert Bid Item(s) (Figure 
8.4). 

Figure 8.4 “Insert Bid Item(s)” command. 

3. Select the desired bid item(s) from the “Insert a Bid Item” dialog box (Figure 8.5) to add to the existing 
MQ sheet and select “Insert” when finished. 

Figure 8.5 “Insert a Bid Item” dialog box. 

4. Select “Insert” when finished to see the additional items. (See Figure 8.6 for resulting summary 
sheet which needs to be renamed.) 
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8.3 Renaming an MQ Sheet or Summary Sheet 

If a summary sheet was not made from workflow 5. Adding Bid Items and MQ sheets and was made from 
inserting additional bid items to an existing MQ sheet via workflow 8.2 Inserting a Bid Item into an Existing 
MQ Sheet (Figure 8.6), you must rename the summary sheet. This tool also works on individual MQ sheets. 

Figure 8.6 Summary sheet created by inserting additional bid items and which needs to be renamed. 

1. From the MQ Sheet section of the Q2P ribbon, select Q2P > MQ Sheet > Rename MQ Sheet (Figure 
8.7). 

Figure 8.7 “Rename MQ Sheet” command. 

2. In the “Rename MQ Sheet” dialog box, enter a name that starts with three numbers, then a hyphen, 
and then a description that uses text and hyphens so the worksheet tab will be placed next to the 
associated bid items (Figure 8.8). 

Figure 8.8 “Rename MQ Sheet” command. 
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An Excel worksheet name cannot exceed 31 characters, be blank, or contain any of the following 
characters \ / : ? * [ ]. A Q2P summary sheet is further limited to no special characters (other than 
hyphens in the name). 

3. Select “OK” to finish and see the changes (Figure 8.9). 

Figure 8.9 Renamed Summary sheet. 

The title at the top middle of the summary sheet is initially generated through the 
renaming tool, but can be modified by the user. (Simply “Pavement Marking” vs. 
“646-Pavement Marking”) 

4. Once items have been combined onto a summary sheet, format your tables by adding the item names, 
changing the title, centering, etc. and begin entering quantities into the table (Figure 8.10). 

Figure 8.10 Example of formatted table to be displayed on MQ Plan Sheets. 

To add a missing category total to the existing MQ sheet, see section 6.1 Add Categories. 
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8.4 Bid Item Used on Multiple Plan Sheets 

Q2P can recognize when a bid item is already being used in another MQ sheet or summary sheet (Figure 8.11). 
If you create a new MQ sheet that includes that used item, Q2P will automatically insert an asterisk at the top 
of the bid item’s description in the newly created MQ sheet (Figure 8.12). 

Figure 8.11 Existing summary sheet with bid items 652.0225 and 652.0235. 

Figure 8.12 Newly generated summary sheet with bid items 652.0225 and 652.0235 & asterisk designation. 

This asterisk is simple text, so users can either use this designation as is or they can modify it. Note that an 
asterisk will not appear on the existing sheet that contains the original bid item and will need to be manually 
added by the user. 

In addition to the asterisk, for quantities shown on multiple sheets, users must include 
a note such as “Quantities shown elsewhere in plan.” 
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9. Deleting Bid Items and MQ sheets 
The Remove Bid Item command (Figure 9.1) is used to delete both a bid item from one or more MQ sheets, 
as well as delete the actual MQ sheet if it only contained the one bid item on it. At this time, Q2P is unable to 
delete an entire summary sheet and each item on that summary sheet must be removed one by one. 

Figure 9.1 “Remove Bid Item” command. 

Before deleting a bid item, it is good practice to either save a copy of the Q2P 
workbook, or to copy the appropriate rows/columns of data back to another 
worksheet or workbook so that data is not lost if it ever needs to be retrieved. 

Do not delete MQ sheets using basic Excel functions (i.e., delete a worksheet by right-clicking the 
worksheet tab and selecting delete or by using Home [tab] > Cells [panel] > Delete [drop-down] > 
Delete Sheets). Always use Q2P commands as using basic Excel methods for this action will cause 
problems in Q2P. 

1. From an active MQ sheet, select Q2P > MQ Sheet > Remove Bid Item to bring up the “Remove Bid Item” 
dialog box (Figure 8.2). 

Figure 9.2 “Remove Bid Item” dialog box. 

2. Select the bid item you want to delete from the MQ sheet. You can only select one bid item at a time. 

3. Select whether to delete it from the current sheet or from all the sheets it is included in. 

4. Select “Remove” to complete the command and to see the resulting sheet (Figure 8.3). 
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Figure 9.3 Summary sheet with bid item 646.6020 removed. 

If the removed bid item was the sole bid item on the MQ sheet, the associated MQ 
sheet would also be deleted from the workbook. This would also be reflected on the 
main “Bid Items” worksheet where the removed bid item would no longer appear 
within the list of bid items. 
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10. Entering and Computing Quantities 
Once all the miscellaneous quantity sheets (MQ sheets) and summary sheets have been inserted into Q2P, 
enter the quantity information. Use the space to the right of the “REMARKS” column to calculate quantities 
as needed. 

Do not rename or delete the “Bid Items” worksheet, and never enter quantities on the main “Bid 
Items” worksheet. Always enter the quantities on the MQ sheets. If quantities are entered in the 
“Bid Items” worksheet and the Update Bid Item(s) command is run, all the manual entries will be 
lost and replaced with the linked total on the associated MQ sheet or summary sheet. 

10.1 Important Formatting Rules 
You can use simple Excel functions to format the rows, columns, and cells to display the data as it will be 
shown in the construction plan miscellaneous quantity sheets, but it is important to maintain some spatial 
relationships between certain cells. Before you start heavily formatting, read the following sections for 
important rules to follow. 

10.1.1 “Total 00X0” Cell 
The “TOTAL 00X0” text must contain that exact text content and format (i.e. TOTAL 0010, TOTAL 0020, 
etc.). Changing it to “TOTAL 10,” for example, will cause errors (e.g. the code will not recognize that 
category to define). Q2P creates the Excel cell Name and a SUM based on this spatial relationship and 
that Name is how the quantity is referenced in various reports, outputs, and the main “Bid Items” 
worksheet (Figure 10.1). 

Figure 10.1 Source of bid item category sum Name. 

If these Names or links are inadvertently deleted or otherwise corrupted, running Q2P > MQ Sheet > 
Rebuild References and Q2P > Tool > Update Bid Item(s) (Figure 10.2) will recreate the links (for only the 
categories included in the list on the bottom of the “Bid Items” worksheet). The category “00X0” text 
listed in column A is optional text for the miscellaneous quantity sheets and does not affect calculations. 

Figure 10.2 “Rebuild References” and “Update Bid Item(s)” commands. 
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Q2P utilizes (=SUM) to create the category totals, and this function will only add 
numbers. If a unit is included in the same cell as the quantity (e.g. “4887 CY” or “33 
FT’” instead of “4887” or “33”), that quantity will be ignored. Enter stations as the 
whole number (without the “+”) to be able to use them in calculations. 

10.1.2 Multiple Categories 
If multiple categories are used for the item, then a “PROJECT TOTAL” must also be shown on the plan 
sheet table (Figure 10.3). This is either automatically generated if an MQ sheet is created with multiple 
categories, or manually created if a category is added to a sheet via the workflow in 6.1 Add Categories. 

Figure 10.3 “Project Total” on a sheet with multiple categories. 
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10.2 Rounding 
It is important to properly round the results of a formula. If cell formatting is used instead, then it is possible 
that when summed on paper, the individual quantities will not add up to the total. 

Figure 10.4 Example of how ROUNDUP makes formula results add up correctly on paper. 

For example, format the cell for locating new passing zones and permanent signing to always show two 
decimals. See FDM 19-5-3.3.3 Rounding Quantities for guidance on rounding quantities. 

Q2P > MQ Sheet > Round Up Quantity (Figure 10.5) will round up the selected quantity to the next integer. 

Figure 10.5 “Round Up Quantity” command. 

Note that there is no way to quickly undo this command, so this should be run when quantities 
are near finalized. To undo, users must activate the cell and manually remove the =ROUNDUP(#,0) 
formula. 

Do not round category totals. Only the actual data rows should be rounded. This is done to ensure 
that the category totals directly sum up the rounded totals and those numbers match the totals 
that are summed up on paper by contractors. 

http://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
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10.3 Recording Computations 
Being able to have the quantity calculations done right alongside the location data (Figure 10.6) is one of the 
advantages of using Q2P to create MQ sheets. 

Figure 10.6 Typical computations. 

When quantity calculations are completed in Q2P, it is very easy to see how a change in pavement thickness, 
for example, will affect project cost. If the change must be made after the MQ sheets are created, the 
computations will carry-through all the way to the PowerPoint sheets, and only the PDF output needs to be 
recreated. 



Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 44 

11. Establishing Unit Prices 
Unit prices are entered on the “Bid Items” worksheet and are always entered into Q2P as present-day costs 
without inflation. Unit prices and quantities are also verified at all Life Cycle changes and PMP phase changes. 

Commonly used sources for item prices include: AASHTOWare Project Estimator™; comparable, nearby and 
recent projects (via Bid Express® or WisDOT bid tab data); averages from WisDOT Central Office Structures; 
and WisDOT Regional Technical Services staff for pavement pricing trends. More details can be found in the 
WisDOT Facilities Development Manual 19-5-5 Construction Estimates. Bid item average price is not 
appropriate to use at PS&E, but can be acceptable earlier in design. 

Be aware of items that have a Pre-Established Price such as those found in the Pre-
Established Price section of the AWP Knowledge Base. 

Do not change the prices of bid items that have pre-established prices. These are typically 
incentive, on-the-job training, and SPV items (with DOL or HRS units). Enter prices to the nearest 
cent. The SPV.0055 and SPV.0075 items are normally pre-established price items, but can be bid 
normally depending on the item details. Pay special attention to these two items. 

Always update the date in Q2P to reflect quantity and/or unit prices revisions. 

http://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
https://awpkb.dot.wi.gov/Content/precon/Estimate/Pre-EstPriceItems.htm
https://awpkb.dot.wi.gov/Content/precon/Estimate/Pre-EstPriceItems.htm
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11.1 Exporting from Q2P into AASHTOWare Project Estimator™ 
1. Select Q2P > Export > To Estimator XML (Figure 11.1). This command will bring up the “Export as 

Estimator XML file” dialog box (Figure 11.2). 

Figure 11.1 Importing Q2P into Estimator help. 

Figure 11.2 “Export as Estimator XML file” dialog box. 

2. Enter the Work Type and Region, then select “Export” to create the XML. 

This command is used to transfer items and quantities into Estimator for obtaining 
the bid regression prices. It is NOT used to create a complete Estimator file for use 
with AWP Preconstruction. As such, all quantities will be imported into Estimator 
under one category (0010). 

3. Once the import file is created, save the XML named with the XXXX-XX-XXToEstimator.xml format in 
your project folder, or use the default path as shown in Figure 11.3. 

Figure 11.3 “Export as Estimator XML file” dialog box after XML creation. 
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4. Launch Estimator and follow the instructions below: 

a. File > Import File 

b. Navigate to exported XML (XXXX-XX-XXToEstimator.xml) and select “Open.” 

5. Verify the project total in Estimator matches the construction cost total in Q2P. 

6. Select and highlight the estimate total (XXXX-XX-XX - $X.XX). 

7. To use the bid regression/average prices in Estimator, select Edit > Update Price Information: Restart. 

8. Enter Work Type, Season, County, etc. 
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11.2 Important Estimator Information 
After restarting an estimate, most items will have a bid regression-based price, but some items will have a 
$0.00 ad hoc price, and SPV items will receive a bid regression/average price that is completely inappropriate 
because the item details are unknown to Estimator. Look out for these prices. 

Typically, users should not be relying on bid regression prices for any item that 
requires a supplemental description as by definition they are unique and cannot be 
bid under a “standard” bid item, but those prices can be a good start for standard bid 
items or reassurance for a price, especially early in the project lifecycle. 

Figure 11.4 Item with supplemental description. 

Estimator will also show blank item descriptions for item numbers that are not in the 
catalog, therefore the To Estimator XML tool in Q2P can be used to check older Q2P 
files for items that may have been retired since their initial selection. 

It is recommended that you save your file prior to making the export to Estimator. Also, none of the data in 
Estimator has a live link to Q2P, so the process must be repeated with each quantity or item change. 
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11.3 Importing from AASHTOWare Project Estimator™ into Q2P 
1. In Estimator, select File > Export Estimate File and name the file XXXX-XX-XXToQ2P.xml and save to 

your project folder. Do not edit this file. 

2. In Q2P, select Q2P > Import > From Estimator XML (Figure 11.5) to bring up the “Import Estimator 
XML file” dialog box (Figure 10.6). 

This command will replace any existing notes, data, etc. that is currently in column K on the “Bid 
Items” worksheet. Before running this command, verify column K is empty. 

Figure 11.5 “From Estimator XML” command. 

Figure 11.6 “Import Estimator XML file” dialog box. Figure 11.7 File path of selected XML file (typically in project folder). 

3. Select “Choose Estimator XML file…” to navigate to your saved file and select “Open.” 

4. Confirm the file, select “Import” (Figure 11.7), then select “OK” on the next window (Figure 11.8). 

Figure 11.8 “From Estimator XML” command. 

5. Rename the column K heading to something like the date of the Estimator run. Otherwise, in the 
future, that data might be mistakenly used when transferring data to/from Estimator, instead of the 
current Q2P unit prices. 
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11.4 Copying Unit Prices 
1. From the “Bid Items” worksheet, select the first cell down from K14 (i.e. the first unit price from 

Estimator) and use Ctrl + Shift + Down Arrow to select the range. 

If there are any blank cells within the selected column, this command will only select the data up 
to that first blank cell. You can continue to hit the Down Arrow until all data is selected. 

2. Use Ctrl + C to copy the prices in column K. 

3. Select the first cell with a price in the Q2P unit price column F. 

4. Right-click > Paste Values (Figure 11.9). 

Figure 11.9 “Paste Values” command. Figure 11.10 Estimator prices successfully copied to “Unit Price” 
column. 

If Estimator prices have a price to the thousandths place (e.g. 10.005), copying those prices into 
the “Unit Price” column will retain those thousandths decimals even though the “Unit Price” 
column is formatted to show a normal currency format (e.g. $10.01). Remember to review the 
unit prices thoroughly prior to creating the ToPrecon.xml for uploading into AWP Precon. 
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12. Viewing “80/20 Rule” Items for Documenting Unit Price Sources 
WisDOT construction projects typically adhere to the Pareto principle and have 80% of their total contract 
cost generated by about 20% of the total items. Therefore, it is important to focus on these items the most 
when creating the engineer’s estimate and then document the basis for the unit price. This documentation 
will aid others who may work on the project and/or be indispensable when responding to a justification 
request after project let. The documentation can be as simple as including a note off to the right of Column K 
in Q2P for the items and should detail the bid item unit price estimate source, such as: nearby, similar projects 
(IDs); Bid Express; Estimator; regional trends; or a combination of these. Also, state whether or not one bidder 
was assumed for the project. More information can be found in FDM 19-5-6 Construction Estimate 
Documentation. 

Items that fall outside the 80/20 rule can still end up being “significant items” and therefore require careful 
consideration and should be documented, especially if they have a history of price fluctuation. 

12.1 Use of Excel’s Sorting Function 
CAUTION! Do not use the Excel Sort command on the “Bid Items” worksheet. Instead, highlight 
and copy the Bid Item list into a new Excel workbook and do any sorting there. 

Sort will only automatically expand the selection to data that is contiguous to the original selection. It will not 
automatically expand the selection when run from an AutoFilter drop-down, even if the data is contiguous. 
Sort also changes the row number of each line, but only does so within the AutoFilter group and does not 
extend past column G in Q2P. This means if Sort is used from the filter drop-down, any price information 
stored off the to the right of “Cost” will be out of order relative to the rest of the data. MQ sheets and summary 
sheets will contain incorrect links as these do not auto-update when using Sort. 

Save your file before sorting and use either of the following workflows in 12.2 or 12.3 to view the “80/20 
Rule.”  

https://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
https://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
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12.2 Using a Number Filter 
1. Save your Q2P project file before sorting. 

2. From the “Bid Items” worksheet, select Review > Changes > Unprotect Sheet (Figure 12.1). 

Figure 12.1 “Unprotect Sheet” command. 

Once a protected sheet is unprotected, using any of the Q2P commands will 
automatically re-protect the sheet. 

3. Use the “Top 10…” Excel Number Filter. 

Figure 12.2 Filter drop-down selected in “Cost” cell. 

4. Change to Top | 20 | Percent. Select “OK.” 

Figure 12.3 Top 10 AutoFilter changed to “Top 20 Percent.” 

The “Bid Items” worksheet is now filtered on the top (by value) 20% of the items. For example, if you 
had 50 bid items in total, this “Top 20% Percent” filter would display the 10 highest cost items 
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assuming you have no duplicate costs (10/50= 20%). Those items may not equal 80% of your project’s 
total cost and you may want to adjust your percentage amount in the number filter. 

Figure 12.4 View of “Bid Items” worksheet data that has been filtered by “Top 20 Percent.” 

5. Highlight the group of “COST” total cells to display the total of the filtered Cost. Excel displays the sum 
of a selection on the bottom right of the status bar. For this example, the top 20% of items is equal to 
about 93% of the total project construction cost. You may choose to re-filter the list down to less than 
20% to display closer to 80% of project cost – just be aware that these are the items that require the 
most scrutiny when developing the engineer’s estimate and require some level of price 
documentation. 

Figure 12.5 Using the selection sum feature of Excel. Figure 12.6 Filter drop-down, used to clear the Number Filter. 

6. Select the filtered cells and use Home > Font > Text Highlight Color to highlight your selected “80/20” 
items to a certain color.   This will differentiate your important items from the rest once you remove 
the number filter.  

7. Select the filter drop-down in the “Cost” cell again to clear the Number Filter (Figure 12.6). 
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12.3 Using Conditional Formatting 
1. Save your Q2P project file before sorting 

2. From the “Bid Items” worksheet, select Review > Changes > Unprotect Sheet (Figure 12.7). 

Figure 12.7 “Unprotect Sheet” command. 

3. Highlight all the cost cells in column G (match the actual range of Costs). 

4. Select HOME > Styles > Conditional Formatting > Top/Bottom Rules > Top 10%... 

Figure 12.8 Conditional Formatting Excel command. 

5. Set the conditional formatting to 20% along with the desired highlighting. Note that this “20%” 
functions the same way as the number filtering method listed above. You may have to adjust this 
percentage amount to identify all your 80/20 items. 

Figure 12.9 Top 10% Conditional Formatting dialog box. 

Now all Costs can be viewed at the same time, with the top 20% items highlighted. 
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Figure 12.10Bid items with the higher Cost items highlighted as they are included in the top 20%. 

The formatted cells will change as new items are added to the project, or existing prices are revised. 

Figure 12.11 Bid items with item 460.6223 Cost no longer highlighted as the unit price was revised down. 

Use a Number Filter to quickly sum these top 20% items to verify that 20% is still the appropriate 
value to use for delineating the items that total around 80% of project cost. This should be done 
especially when major changes have occurred to the project estimate. 

6. To clear Conditional Formatting, use HOME > Styles > Conditional Formatting > Manage Rules… while 
the range is still selected. 

Figure 12.12 Conditional Formatting Rules Manager which allows deletion of set rules. 
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13. Creating the Miscellaneous Quantity Plan Sheets 

13.1 Setting up the Power Point Slide Template 
1. Navigate to the Q2P web page to access and download the PowerPoint templates for creating the MQ 

sheets. 

2. Open a new Miscellaneous Quantities plan sheet template, titled PowerPoint MQ Plan Sheet.pptx. 
There is also a rotated plan sheet template for use as needed. 

Figure 13.1 PowerPoint sheet templates found on Q2P website. 

3. Save the PowerPoint sheet working file in the same directory as the project’s Q2P workbook working 
file and name it 030200_mq.PPTX or XXXX-XX-XX_mq.PPTX. It should remain there until after PS&E. 

4. Fill in the project title block information. This is done by editing the “Slide Master.” Go to VIEW > 
Master Views > Slide Master. 

Figure 13.2 Normal View. 

https://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx
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Making edits to the “Slide Master” will translate those edits to be used on all sheets. 

5. Click on the Slide Master #1 and then edit the text boxes at the bottom of the plan sheet. 

Figure 13.3 Slide Master View. 

Note that there is a second master slide which is blank. This can be used to create a 
second sheet, if different project information is required within the same PPTX file. 

6. When finished, click the “Close Master View” button. 

7. In Normal view, use HOME > New Slide to create multiple copies of the slide as needed to 
accommodate the Q2P miscellaneous quantity data. 

Figure 13.4 PowerPoint New Slide. 
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13.2 Copying Data onto PowerPoint Slide 
1. In Q2P, navigate to an MQ sheet and highlight the range of data to be included on the plan sheet. 

2. Select PAGE LAYOUT > Print Area > Set Print Area. 

3. Right-click < Copy or select HOME > Clipboard > Copy to copy the selection. 

Q2P works best when a Print Area is linked to PowerPoint since this allows users to 
insert rows and columns and have those changes reflected in PowerPoint. If only a 
cell range is selected, rows will shift out of view when new ones are inserted into the 
table. Alternatively, Use FORMULAS > Defined Names > Define Name, to break-up 
sheets that must span two PowerPoint sheets. 

4. NON-LINKED MQ SHEETS – In PowerPoint, Right-click > Paste Options > Keep Source Formatting.   This 
method doesn’t have any links to potentially break, but will require a manual Copy + Paste for every 
change to any MQ table in your Q2P file. 

5. LINKED MQ SHEETS – In PowerPoint, select HOME > Clipboard panel > Paste Drop-down menu > 
Paste Special… and select the “Paste link” radio button. Choose “Microsoft Excel Worksheet Object”. 

Figure 13.5 Paste Special in PowerPoint. 

Make sure the “Display as icon” checkbox is NOT checked. 
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6. Use the Right-click > Format Object to scale to a standard percent for the sheets, or set the insertion 
point manually if attempting to align multiple items. 

Figure 13.6 Right-Click Menu 

Figure 13.7 Format Object dialog box. 

Note that “Lock aspect ratio” needs to be checked. 
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7. Use the standard PowerPoint tools to create lines (HOME > Drawing) to separate items. 

Figure 13.8 Drawing lines in PowerPoint. 

Holding the shift key while creating or lengthening a line will lock in the direction to 
90°/180°/270°/360. 

Once miscellaneous quantity sheets are linked to PowerPoint, the Q2P XLS file should not be moved or 
renamed, as links are not relative, they are absolute. Under the FILE > Info > Related Documents > Edit 
Link to Files, the links may be reviewed for problems and file source locations manually updated for each 
link, one at a time, if necessary. 

Figure 13.9 Use “Edit Links to Files” to review links between Q2P and PowerPoint. 

Always have the associated Q2P workbook open BEFORE opening the PowerPoint MQ plan sheets. 
This will avoid extremely slow processing due to PowerPoint needing to open and close Excel to 
update every link in the file. 
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13.3 Printing the Miscellaneous Quantity Sheets 
The MQ plan sheets must conform to the standards in FDM 15-1-30, Miscellaneous Quantity Sheet. Use the 
following steps to create the PDF file from PowerPoint for the final electronic plan (ePlan). 

1. Select FILE > Print and set the Printer to “Adobe PDF” and verify “All Slides” are to be printed. 

2. Click “Printer Properties” to access the Print dialog box. 

Figure 13.10 Accessing printer properties. Figure 13.11 Basic Print Settings for Adobe PDF. 

3. Set “Adobe PDF Page Size” to 11 x 17. 

4. Change the “Layout” to Landscape and hit “OK.” 

Figure 13.12 Layout changed to Landscape. 

5. Select “Print” and save the PDF as 030200_mq.pdf in the SheetsPlan\pdf folder in the Civil 3D directory 

http://wisconsindot.gov/rdwy/fdm/fd-15-01.pdf
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14. Print Project Cost Report 
The Cost Report is the engineer’s estimate, grouped by category. 

1. Prior to creating a Cost Report, use Q2P > Project > Checked By and enter the appropriate initials and 
date. This information will appear on the Cost Report footer. 

2. Select Q2P > Export > Generate Cost Report (Figure 14.1) to generate and print (Figure 14.2) the project 
cost report which displays the estimate totals by category (Figure 14.3). 

Figure 14.1 “Generate Cost Report” command. 

Figure 14.2 Generate Cost Report window after report generation is complete. 
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Figure 14.3 Q2P Cost Report. 

3. Save the PDF to your project folder. Alternatively, the main “Bid Items” worksheet can be printed from 
the standard Excel print dialog to disregard categories and just view the item costs across all categories. 

Delete unused category rows (using Excel commands) from the MQ sheets and run Q2P > Tool > 
Update Bid Item(s) to refresh the links to the main “Bid Items” worksheet. 
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Figure 14.4 MQ sheet with unused category left in place. 

A miscellaneous quantity sheet must only contain the categories that are required. 
Do not keep empty CATEGORY 0020, 0030 totals on the MQ sheet (unless intended to 
be used at a later time). 

The 0 quantity/cost will NOT appear in either the Cost Report or the upload XML to AWP. 
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15. Creating the Upload File for AASHTOWare Project Preconstruction™ 
Prior to creating the upload file for AWP Preconstruction, verify all empty categories are deleted 
from each miscellaneous quantity sheets. 

1. Select Q2P > Export > To AWP Precon XML (Figure 15.1).  This command will bring up the “Export as 
Estimator XML file” dialog box (Figure 15.2). 

Figure 15.1 “To AWP Precon XML” command. 

Figure 15.2 “Export as AWP XML file” dialog box. 

2. Enter the Work Type and Region, then select “Export” to create the XML. 
3. Once the import file is created, save the XML named with the XXXX-XX-XXToPrecon.xml format in your 

project folder, or use the default path as shown in Figure 15.3. 

Figure 15.3 “Export as AWP Precon XML file” dialog box after XML creation. 
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Figure 15.4 Sample XXXX-XX-XXToPrecon.xml generated by Q2P. 

4. Review the XXXX-XX-XXToPrecon.xml file (Figure 15.4) for completeness and/or errors prior to 
uploading into AWP Preconstruction. Pay special attention to the items with supplemental descriptions. 

Note how the “Item Description” from Q2P is not actually exported to AWP Preconstruction. Rather, it is 
populated in AWP Preconstruction from the item number. 
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16. Importing the File into AASHTOWare Project Preconstruction™ 
Prior to importing the XXXX-XX-XXToPrecon.xml into AWP Preconstruction, verify that the 
Project is properly setup in AWP Preconstruction. This will avoid errors during the upload process. 

For instructions on uploading the XXXX-XX-XXToPrecon.xml file into AWP Preconstruction, see the WisDOT 
AASHTOWare Project™ (AWP) Knowledge Base. The help documentation refers to the XXXX-XX-XXToPrecon.xml 
file originating from Estimator, but the Q2P version is also a valid source (Figure 15.3). 

Figure 16.1 Navigation to “Importing an Estimate into Preconstruction.” 

https://awpkb.dot.wi.gov/content/default.htm
https://awpkb.dot.wi.gov/content/default.htm
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APPENDICES 

Appendix A.       Troubleshooting 

A-1   “########” Displays in a Cell 
When a cell in Excel does not have sufficient width to display the entire number, it will display a cell filled 
with “#”. Increasing the width of the column will fix the issue. 

Figure A-1.1 Insufficient column width. 

Double-clicking in the area between columns headings (columns I and J in our example) will automatically 
change the width to an amount that will allow all content to display properly. Excel will do this when the 
mouse cursor has changed to the Excel “resize column width” cursor. 

Figure A-1.2 Resize column width cursor. 

You can also right-click on the column name (I) and select “Column Width…” to change the width to a set 
larger value. 

Figure A-1.3 Right-click menu for accessing the “Column Width…” command. 
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A-2   “#REF !” Appears in the Quantity Total on the main “Bid Items” Worksheet 
This error occurs most often when a category has been deleted from an MQ sheet and Update Bid Item(s) 
is run before Rebuild References. The solution is to first rebuild the references after deleting the category, 
which will create the proper links, then run the Update Bid Item(s) command. 

Figure A-2.4 “#REF!” error on “Bid Items” worksheet after deleting category from MQ sheet. 

A-3   Q2P Ribbon Fails to Load 
If the Q2P ribbon fails to load when the workbook is opened, refer to the “Repair Q2P Excel Add-In” tool 
mentioned in section 1. Before You Get Started. 

A-4   Small Triangles Appear in Cells 
If “Error Checking” is enabled in Excel, then small triangles will appear in cells when it believes there is an 
error (such as the multiple leading zeros in category numbers, etc.). 

Figure A-4.5 Excel error checking displaying small triangles in cells – will also display in PowerPoint. 

To stop Excel from displaying these error triangles, select FILE > Options > Formulas. Then under “Error 
Checking,” unselect “Enable background error checking”. 
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Figure A-4.6 Disabling Excel error checking. 

A-5   “Tab” Key Does Not Work in Newly Created MQ Sheet 
There is a known bug that when creating a new MQ sheet, the “Tab” key will not work on that sheet at 
first. The solution is to switch to a different MQ sheet and then switch back to refresh its functionality. 

A-6   Renaming MQ Sheet Via Right-Click Inhibits Q2P Functionality 
If an MQ sheet is renamed via the Excel right-click menu instead of using the proper “Rename MQ Sheet” 
command, that MQ sheet will no longer be recognized as a Q2P sheet and all the Q2P commands will 
cease functioning on that sheet. To rectify this, simply right-click again to revert the name to its original 
name. If necessary, use the “Create MQ Sheet” command to bring up the window and scroll to one of the 
bid items on the renamed sheet and that will showcase the original sheet name. While quantities will still 
be updated on the Bid Items worksheet, other functionality of Q2P will no longer work. This includes the 
creation of the Cost report and the ability to generate any of the XML files.  
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A-7   “This worksheet is not a valid Misc Qty sheet,…” Error Message 
This error message appears when Q2P loses connection with a worksheet through the fact that the name 
ranges that Q2P utilizes no longer are able to connect to the worksheet. This is most commonly caused 
by the renaming of a worksheet via the right-click method.    The fix in that case is described in A-6 above.  
This error additionally can occur when trying to use Q2P ribbon commands with two Q2P excel workbooks 
open at the same time.   Normally, closing both workbooks without saving, will fix the problem causing the 
error message.  

A good tip is to periodically use the Update Bid Items button when on the Bid Items worksheet to update 
all the items in the workbook.   If this command takes longer than 1 minute to run and it seems to hang 
up, there is an error with some of the data and the XML creation functionality will likely not work.  
Individually look through the worksheets and try to run a Q2P command from the ribbon such as Insert 
Bid Item(s) to try and get this error message to pop up.   When it does pop up, that worksheet is at least 
part of the cause of the updating bid items command not working.   Look to see if that worksheet was 
renamed incorrectly by using the process mentioned above in A-6. If the errors persist, contact Q2P 
support. 
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Appendix B.       Miscellaneous Helpful Information 

B-1   Getting Help 
Request help with Quantities 2 Plans by contacting the region Q2P power users in your office found here 
or by sending an email to DOT Q2P Support. If the issue is believed to be more of a general problem with 
Excel or PowerPoint, WisDOT staff should contact the DOT IT Service Desk. 

B-2   Quick Navigation 
There are several ways to quickly navigate between the “Bid Items” worksheet and the MQ sheets. 

To navigate to the “Bid Items” worksheet, users can use either of the following: 

1. From the Q2P ribbon, Q2P > Tool > Go to “Bid Items”. 

Figure B-2.1 “Go to “Bid Items”” command. 

2. From an MQ sheet or summary sheet in any cell, Right-click > Return to “Bid Items”. 

Figure B-2.2 “Return to “Bid Items”” command from the right-click menu. 

https://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx
mailto:DOTQ2P@dot.wi.gov
mailto:DOTITServiceDesk@dot.wi.gov
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To navigate to a desired MQ sheet or summary sheet: 

Figure B-2.3 “Go to MQ sheet” dialog from the right-click menu. 

1. From the “Bid Items” worksheet, select the desired bid item. 
2. Right-click > Go to sheet(s) include “XXX.XXXX”. 
3. Select desired MQ sheet or summary sheet. 
4. Select “Go.” 
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Users can also use Excel’s native quick navigation: 

Figure B-2.4 Right-click menu from bottom left arrows displaying all sheets. 

1. Right-click on bottom left arrows. 
2. Scroll to desired worksheet. 
3. Select “OK.” 

B-3   Excel® Tips and Tricks 
• To bypass automatic formatting of data in a cell, insert an apostrophe in front of the data. 

• The format painter tool under Home > Clipboard is useful for quickly copying the 
formatting of one cell or range to another. 

• To quickly flip though worksheets, use Ctrl + Page Up/Down. 

• Excel will only sort data that is contiguous to the initial selection. Also, even if the data is contiguous, 
it will not sort outside of an autofilter group. 

• The N function can be repurposed for inserting comments into formulas. Using it will add 0 to the end 
of the formula, as the N function generally converts text (other than TRUE) to 0. This is cleaner than 
using Excel comments as it will not show a red triangle in the cell. Append a formula with: 

+ N(“This is the comment”) 
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B-4   Complex Formulas 
In addition to relatively simple computations, more complex formulas can be written. 

One common reoccurring issue with permanent signing MQ sheets is that stop signs have their SF 
calculated from the entered length X width (with a simple unrounded formula such as “=U9*W9/144”), 
rather than octagonal area. The correct value from the sign plate can be used by using a lookup table: 

=IF(K9="R1-1",VLOOKUP(U9,tables!$B$7:$C$14,2,FALSE), 
IF(K9="ZX-X",VLOOKUP(U9,tables!$B$79:$C$86,2,FALSE), 
IF(ISNUMBER(SEARCH("M",K9)),"-", 
IF(ISBLANK(K9),"", 
ROUND(((U9*W9)/144),2))))))))) 

Figure B-4.5 Excerpt from tables worksheet. (Lookup array highlighted) 

Additional formulas can be used to show category subtotals on the “Bid Items” worksheet. 

For CATEGORY 0010, with the quantity to be reported in column N: 

=IF(A13<>"x","",IF(ISERROR(INDIRECT("TOTAL"&B13&"_0010")),"<CAT>",(INDIRECT("TOTAL"&B 
13&"_0010")))) 

For CATEGORY 0010 cost: 

=IF(A13<>"x","",IF(N13="<CAT>","<CAT>",IF(ISERROR(D13),0,IF(D13="",0,IF(D13=" 
",0,IF(D13="<Error>",0,F13*N13)))))) 

Adjust the red values for each category/location. These formulas can cause slowdowns in Excel with larger 
projects. 

It is important to always build a formula that other users will be able to understand. That might 
require using individual cells that are labeled for both variables and constants. 

Other formulas can be written with Excel for computing incentives, etc. 

Q2P users are encouraged to submit their custom formulas or workflows to DOT Q2P Support, so they can 
be added to the User Guide or otherwise shared. 

mailto:DOTQ2P@dot.wi.gov


Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 75 

B-5   Making Notes in Q2P 
On the “Bid Items” worksheet, the columns past column G (except for column K and L) can be used to 
make notes about any particular item that is suitable for Estimate Documentation. Unit price source 
information and tagging the items in the FIIPS Preliminary Quantities groups are the most common notes 
recorded in Q2P. 

Column K and L should be avoided as the command for importing prices from Estimator and AWP 
will overwrite these columns. Extraneous columns including K and L can be hidden when 
formatting the estimate documentation. 

Figure B-5.6 Making notes in Q2P. 

The commonly used abbreviations for FIIPS Preliminary Quantities (Roadbuilder Quantities) are: 

ASPH (Asphalt Pavement TON), CONC (Concrete Pavement SY), EXCV (Excavation CY), BCRS (Base Course 
TON), BRDG (Bridge SF), MILL (Milling SY), GRND (Diamond Grinding SY), STRP (Pavement Marking LF), and 
RUBL (Rubbilized Pavement SY). Obviously, some quantities need to be converted to the correct unit of 
measure prior to being totaled for entry into FIIPS. 

The notes can serve as the required documentation of how unit prices were arrived at for the engineer’s 
estimate (for the 80/20 rule items). When making notes about unit price sources, be sure to include a 
general project statement as to whether or not “one bidder” was assumed. 

B-6   Finding Contingency Let Dates in FIIPS 
The Earliest Possible Let is obtained from the FIIPS. These are considered to be Priority 1 advanceable and 
have the PS&E submitted early. Priority 2 code projects are ones that are the top region priority for 
advancement and C.O. may request the PS&E package as needed. The regions may also have priority 10 
contingency projects that don’t have early lets in FIIPS and are just kept for regional balancing due to 
individual project delays, etc. rather than statewide program issues or unbalanced lettings. 

Find the earliest possible let in FIIPS by checking Project > Estimate… and view the LET project information. 
If the “Earliest schedule date” differs from the “Schedule date” then the project is a priority 1 contingency 
and must be submitted early. PMP should have the base schedule set to the earliest date and the project 
developed accordingly. 
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This contingency date can be manually added to Q2P, above the PSE Date field, if the designer finds that 
information helpful to display. 

Consultants should request this information from the WisDOT Project Manager. 

B-7   Migrating Older Q2P files to version 3.2.1.0 and later 
Q2P was updated in the fall of 2024 to reflect a change in AWP; requiring designers to now choose a spec. 
book year for their project.   As part of this update, the miscellaneous quantity sheet format was updated 
to remove the empty spacer columns between bid items.   This was done to make it easier to import the 
tables into Civil 3D and help eliminate errors that would get created when users needed to manually insert 
extra columns for certain pavement marking and traffic control items. A migration tool was added to the 
latest version to assist in converting existing worksheets into the new format. 

Check to make sure that the existing Q2P file is in good working order. Navigate to the “Bid Items” 
worksheet and go to the Tool section of the Q2P ribbon and click on the Update Bid Item(s) button. On 
the prompt window that appears, click the option that says “Update All in this Worksheet” and hit “Yes”. 
You should get a confirmation window showing the number of bid items updated. Double check that your 
estimate total is still the same and that there are no errors in any of the quantity cells. If your Q2P “hangs” 
or it’s taking over 2 minutes to update all the items, or your estimate total changed, there are likely some 
issues with your file, and it would be best to start a new Q2P file and copy over your MQ sheet data. Just 
remember to only copy over the rows between the header row and the row with category totals.  Copying 
over the header or category total rows can cause some issues with data references in the new Q2P file. 

If all of the items were updated, follow the instructions below to migrate your file: 

• Check your worksheets to make sure that you don’t have any merged cells in your MQ tables, 
especially for some of the header rows.  Unmerge any cells that you find prior to proceeding to 
the next step.  The following workflow will not work to remove the spacer columns as it considers 
the merged cell data to be part of the column and therefore it won’t remove the spacer column. 

• In the Help section of the Q2P ribbon, use the Migrate button to convert your worksheets to the 
new version without spacer columns in them. This button will create a copy of your Q2P file with 
the same name and add “_Replica.xlsx” after it and will edit the Replica file to remove the spacer 
columns in the MQ tables worksheets.  Once it is complete, there will be a confirmation window 
that pops up telling you the default saved location of the replica file. Before closing, save and 
rename your XXXXXXXX_Replica file.xlsx to the location you prefer if the default location isn’t 
where you like.  This new replica file will be your working file going forward. 
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• Next step is to check over every MQ sheet table and make sure that all the spacer columns were 
deleted.  Be aware that the tool will only delete columns that are empty.  If there are any 
numbers or characters in the entire column, it will not be deleted.  The spacer columns in the 
MQ table need to be deleted in order to have Q2P insert and remove items properly.  If a spacer 
column still exists, then you will need to manually move or delete that data from cells in the 
spacer column.  DO NOT DELETE THE SPACER COLUMN MANUALLY!  After the data is removed, 
re-run the Migrate command and then use the new file you get from that process.  You will also 
notice that any calculations and work you did off to the side of the MQ tables have moved over 
as Q2P also deleted the empty columns between the MQ tables and that work.  You can insert 
new columns to space this work away from the MQ table. 

• Once the MQ tables have been reviewed, click on Project Setup in the Project section of the Q2P 
ribbon.  You will see a new field for you to choose a Spec. book year. Choose the spec book year 
that you want to use for your current bid item list. For example, choose ‘25’ for the 2025 spec 
book.  Choose book ‘03’ for using 2024 or earlier spec years.  After you choose the spec book and 
hit OK, Q2P will appear to freeze or lock up. It is not frozen, just wait about 1 minute and the 
dialog window will disappear after Q2P has contacted the AWP database and made a copy of the 
list of bid items for the chosen spec. book year. (You will notice in the header information on the 
Bid Items worksheet, that above the PSE Date will be a ‘25’ if you chose the 2025 spec book. When 
you start a new Q2P file you’ll see the label for Spec year, but for existing, just the value of the 
Spec year field will get inserted.  This is just a visual issue that comes with updating an existing 
workbook.) 

• Then click on Project Bid Items in the Data section of the Q2P ribbon and in the window that 
appears, you should see red colored text at the top. Click on that text to bring up the 
reconciliation tool.  Follow instructions in section 3.3 of this guide on how to update your bid 
items and add the new items to your file. 

• Your file should now be reformatted and ready to use.  Be aware that if you have already created 
MQ sheets in PowerPoint or C3D and have them linked to your Q2P file, you will need to redo the 
links as those links point to the old file. If you had links in your worksheets to other documents 
or files, check that those links are still working in the replica copy of Q2P. 
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Appendix C.       Confidentiality of Engineer’s Estimate and Pre-award Bid Data 
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